Nota:
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
Este artículo le ayuda a resolver el problema que se produce al intentar seleccionar un documento en la ventana Entrada de transacción de ventas.
Se aplica a: Microsoft Dynamics GP
Número de KB original: 866440
Introducción
En este artículo se describe un problema que se produce al intentar seleccionar un documento en la ventana Entrada de transacción de ventas. En este artículo también se proporcionan posibles causas del problema y una resolución.
Nota:
Antes de seguir las instrucciones de este artículo, asegúrese de que tiene una copia de seguridad completa de la base de datos que puede restaurar si se produce un problema.
Síntomas
Al intentar seleccionar un documento en la ventana Entrada de transacción de ventas en Microsoft Dynamics GP, recibirá el siguiente mensaje de error:
Otro usuario está editando este documento.
Causa
Este problema puede producirse por muchas razones. Esto incluye, entre otras, las causas siguientes:
- Un usuario está intentando acceder a un documento desde la ventana Entrada de transacción de ventas mientras otro usuario está editando el mismo documento.
- Se interrumpió un registro. La interrupción provocó que los registros estuvieran dañados o bloqueados.
Solución
Paso 1: Hacer que todos los usuarios salgan de Microsoft Dynamics GP o Microsoft Business Solutions - Great Plains
Paso 2: Eliminar los registros
Para que borremos los registros bloqueados para usted, siga estos pasos:
Debe hacer que todos los usuarios salgan de Microsoft Dynamics GP antes de ejecutar los scripts de SQL. Para borrar los registros bloqueados usted mismo, ejecute las siguientes instrucciones en una herramienta de consulta de Microsoft SQL:
DELETE DYNAMICS..ACTIVITY DELETE DYNAMICS..SY00800 DELETE DYNAMICS..SY00801 DELETE TEMPDB..DEX_LOCK DELETE TEMPDB..DEX_SESSION